sexta-feira, 20 de novembro de 2009

ERRO GLIBCXX NO KARMIC

Você clica no ícone do Googleearth e ele não inicia?
Experimente chama-lo pelo terminal:
$googleearth
Provavelmente vai aparecer o erro:

./libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./libgoogleearth_lib.so)

SOLUÇÃO:
1) Edite o arquivo abaixo e altere o seu conteúdo:
$ sudo gedit /etc/X11/xinput.d/all_ALL

Cole o trecho abaixo acima de
XIM=
XIM_PROGRAM=
XIM_ARGS=
XIM_PROGRAM_XTRA=

Colar:

XIM=SCIM
XIM_PROGRAM=/usr/bin/scim
XIM_ARGS="-d"

XIM_PROGRAM_SETS_ITSELF_AS_DAEMON=yes


2) Entre na pasta do googleearth e altere as libs:
$ cd ~/google-earth

$ sudo mv libstdc++.so.6 libstdc++.so.6.orig
$ sudo ln -s /usr/lib/libstdc++.so.6.0.9 libstdc++.so.6

$ sudo mv libgcc_s.so.1 libgcc_s.so.1.orig
$ sudo ln -s /lib/libgcc_s.so.1

Nenhum comentário:

Postar um comentário